import re
regex = re.compile(r"\b[A-Z].*?\d{1,2}\.\d{1,2}\.\d{2,4}(?=\s+[A-Z]|$)", flags=re.MULTILINE)
test_str = ("N678 à p. du 11.6.23 C+23.6.23 N−14.,24.7.23\n\n"
"N678 N−12.,13.12.22,18.,19.,31.1.,9.2.,7. au 10.,13. au 17.,20.,21.,22.,28.\n"
"au 31.3.,6.,13.,19.,20.4.,5.,8.5.23\n\n"
"N68 du 12.6. au 3.9.23 C+23.6.,15.8.23 N-18.,25.6.,2.,17. au 21.,23. au 28.,31.7.,3.,4.,7.,8.,9.,27.8.23\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")