using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]+";
string input = @"Тест 123 тест 123 тест
тест 567 тест
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}