$re = '/[0-9]+/';
$str = 'Тест 123 тест 123 тест
тест 567 тест
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);