package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[0-9]+`)
var str = `Тест 123 тест 123 тест
тест 567 тест
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}