use strict;
my $str = 'https://www.reddit.co.jp/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://www.reddit.com/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://old.reddit.com/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://reddit.co.jp/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://reddit.com/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://localhost/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://127.0.0.1/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://127.0.0.1:3000/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://localhost:3000/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://reddit.com:3000/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://new.reddit.com:3000/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://420.reddit.com:3000/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
ftp://ftp.mitsu.xd:6969/secret-linux-isos
smtp://69.420.com/does-smtp-even-supports-paths?idk=pls%20help
https://pbs.twimg.com/media/FXiW8wAXwAAqKe3.jpg?name=orig
# Don\'t match these:
https://foo#bad.com/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://.../r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://1024.0.0.7/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://360.0.0.7/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://127.w.0.1/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
';
my $regex = qr/^((?:https?|ftp|smtp):\/\/)?((?:[a-z0-9]+\.)*[a-z]+|(?:(?:25[0-5]|2[0-4]\d|1?\d{2}|\d)\.){3}(?:25[0-5]|2[0-4]\d|1?\d{2}|\d))(:\d+)?(\/.+\/?)*$/mp;
if ( $str =~ /$regex/g ) {
  print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
  # print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
  # print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}