import Foundation
let pattern = #"^((?:https?|ftp|smtp):\/\/)?((?:[a-z0-9]+\.)*[a-z]+|(?:(?:25[0-5]|2[0-4]\d|1?\d{2}|\d)\.){3}(?:25[0-5]|2[0-4]\d|1?\d{2}|\d))(:\d+)?(\/.+\/?)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
https://www.reddit.co.jp/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://www.reddit.com/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://old.reddit.com/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://reddit.co.jp/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://reddit.com/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://localhost/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://127.0.0.1/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://127.0.0.1:3000/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://localhost:3000/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://reddit.com:3000/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://new.reddit.com:3000/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://420.reddit.com:3000/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
ftp://ftp.mitsu.xd:6969/secret-linux-isos
smtp://69.420.com/does-smtp-even-supports-paths?idk=pls%20help
https://pbs.twimg.com/media/FXiW8wAXwAAqKe3.jpg?name=orig
# Don't match these:
https://foo#bad.com/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://.../r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://1024.0.0.7/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://360.0.0.7/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://127.w.0.1/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)