# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((?:https?|ftp|smtp):\/\/)?((?:[a-z0-9]+\.)*[a-z]+|(?:(?:25[0-5]|2[0-4]\d|1?\d{2}|\d)\.){3}(?:25[0-5]|2[0-4]\d|1?\d{2}|\d))(:\d+)?(\/.+\/?)*$"
test_str = ("https://www.reddit.co.jp/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
	"https://www.reddit.com/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
	"https://old.reddit.com/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
	"https://reddit.co.jp/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
	"https://reddit.com/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
	"https://localhost/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
	"https://127.0.0.1/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
	"https://127.0.0.1:3000/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
	"https://localhost:3000/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
	"https://reddit.com:3000/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
	"https://new.reddit.com:3000/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
	"https://420.reddit.com:3000/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
	"ftp://ftp.mitsu.xd:6969/secret-linux-isos\n"
	"smtp://69.420.com/does-smtp-even-supports-paths?idk=pls%20help\n"
	"https://pbs.twimg.com/media/FXiW8wAXwAAqKe3.jpg?name=orig\n\n"
	"# Don't match these:\n"
	"https://foo#bad.com/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
	"https://.../r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
	"https://1024.0.0.7/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
	"https://360.0.0.7/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
	"https://127.w.0.1/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
    
    print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
    
    for groupNum in range(0, len(match.groups())):
        groupNum = groupNum + 1
        
        print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.