package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)\b(r(a|à|á|â|ä|æ|ã|å|ā)p(e|3|è|é|ê|ë|ē|ė|ę))\s*`)
var str = `rape grape g rape ra pe rapes`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}