import re
regex = re.compile(r"\b(r(a|à|á|â|ä|æ|ã|å|ā)p(e|3|è|é|ê|ë|ē|ė|ę))\s*", flags=re.IGNORECASE | re.MULTILINE)
test_str = "rape grape g rape ra pe rapes"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")