import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"\"\"(.|\\n)*\"\"\"\\n";
final String string = " keepme()\n"
+ " \"\"\"\n"
+ " Remove this silly comment please\n"
+ " and this one too\n"
+ " \"\"\"\n"
+ " alsokeepme()";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}