$re = '/"""(.|\n)*"""\n/m';
$str = ' keepme()
"""
Remove this silly comment please
and this one too
"""
alsokeepme()';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);