const regex = /\bfrom company\b.*?\b(?<!\$|[\d.])(\d+)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bfrom company\\b.*?\\b(?<!\\$|[\\d.])(\\d+)\\b', 'g')
const str = `This is invoice from company XYZ - \$1234545 product name 31h10 , \$456.12 product number g456, 123f 456 information invoice unit cost \$12.0 and invoice total \$1343.00
This is invoice from company ABC - 1234545 product name and information invoice total cost \$6777 and invoice unit cost \$654`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}