re = /\bfrom company\b.*?\b(?<!\$|[\d.])(\d+)\b/
str = 'This is invoice from company XYZ - $1234545 product name 31h10 , $456.12 product number g456, 123f 456 information invoice unit cost $12.0 and invoice total $1343.00
This is invoice from company ABC - 1234545 product name and information invoice total cost $6777 and invoice unit cost $654'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end