import re
regex = re.compile(r"\bfrom company\b.*?\b(?<!\$|[\d.])(\d+)\b")
test_str = ("This is invoice from company XYZ - $1234545 product name 31h10 , $456.12 product number g456, 123f 456 information invoice unit cost $12.0 and invoice total $1343.00\n\n"
"This is invoice from company ABC - 1234545 product name and information invoice total cost $6777 and invoice unit cost $654")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")