package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\S+(?: \S+)*)( {2,})`)
var str = `This line with sometimes more than 1 space needs to be captured in 3 matches with 2 groups.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}