$re = '/(\S+(?: \S+)*)( {2,})/m';
$str = 'This line with sometimes more than 1 space needs to be captured in 3 matches with 2 groups.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);