re = /(\S+(?: \S+)*)( {2,})/m
str = 'This line with sometimes more than 1 space needs to be captured in 3 matches with 2 groups.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end