// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\b\d{5})((##DEU-Akten|[PZ] ?DEU)|(##Schutzerstreckungen|W ?WOS)|(##Widerspruch|[BRK] ?([A-Z]{2}|[MZ][123]|R1|T[12])([-_]?([A-Z]{2}|[MZ][123]|R1|T[12]))?(-?\d+)?(\.?\d+)?)|(##mitLand|([PZGDWSEL]|[NVYTXCUAK]) ?((((HK-?CN)|(([A-Z]{2}|[MZ][123]|R1|T[12])(-?EP|-?EM|-?AP|-?OA)?))(-?WO|-?W\d+?)?|S))(-?\d+)?)|((##ohneLand|[NVYTXCUAK])(-?\d+)?))").unwrap();
let string = "62877K";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}