import Foundation
let pattern = ###"(\b\d{5})((##DEU-Akten|[PZ] ?DEU)|(##Schutzerstreckungen|W ?WOS)|(##Widerspruch|[BRK] ?([A-Z]{2}|[MZ][123]|R1|T[12])([-_]?([A-Z]{2}|[MZ][123]|R1|T[12]))?(-?\d+)?(\.?\d+)?)|(##mitLand|([PZGDWSEL]|[NVYTXCUAK]) ?((((HK-?CN)|(([A-Z]{2}|[MZ][123]|R1|T[12])(-?EP|-?EM|-?AP|-?OA)?))(-?WO|-?W\d+?)?|S))(-?\d+)?)|((##ohneLand|[NVYTXCUAK])(-?\d+)?))"###
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"62877K"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)