import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?<!\\d\\.|\\/)\\d+(?:\\.[05])?(?:\\/\\d+(?:\\.[05])?)?$";
final String string = "1\n"
+ "5.5\n"
+ "0/0.5\n"
+ "147/147.5\n"
+ "7.0/8\n"
+ "10.0\n\n"
+ "7.8\n"
+ "2.\n"
+ "6.5/\n"
+ "1./2\n"
+ "1./2.5\n"
+ "/147.5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}