re = /\b(?<!\d\.|\/)\d+(?:\.[05])?(?:\/\d+(?:\.[05])?)?$/m
str = '1
5.5
0/0.5
147/147.5
7.0/8
10.0
7.8
2.
6.5/
1./2
1./2.5
/147.5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end