const regex = /\b(?<!\d\.|\/)\d+(?:\.[05])?(?:\/\d+(?:\.[05])?)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?<!\\d\\.|\\\/)\\d+(?:\\.[05])?(?:\\\/\\d+(?:\\.[05])?)?$', 'gm')
const str = `1
5.5
0/0.5
147/147.5
7.0/8
10.0
7.8
2.
6.5/
1./2
1./2.5
/147.5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}