package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z][\w\s]+[?.!]$`)
var str = `This sentence is correct.
this sentence does not start with capital.
This sentence is not correct`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}