re = /^[A-Z][\w\s]+[?.!]$/m
str = 'This sentence is correct.
this sentence does not start with capital.
This sentence is not correct'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end