#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*?\s-\s([^.]*?)\s*\."
Local $sString = "PATIENT: 2029985 - COLLINS, JUNIOR ." & @CRLF & _
"PATIENT: 1235231-02 - JERRY JR, PATRICK ." & @CRLF & _
"PATIENT: 986435--EXP-- - JULIUS, DANIEL ." & @CRLF & _
"PATIENT: 2021118-02 - DRED-HARRY, KEVIN ." & @CRLF & _
"PATIENT: 2021118-02 - DRED-HARRY, JASON."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")