package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*?\s-\s([^.]*?)\s*\.`)
var str = `PATIENT: 2029985 - COLLINS, JUNIOR .
PATIENT: 1235231-02 - JERRY JR, PATRICK .
PATIENT: 986435--EXP-- - JULIUS, DANIEL .
PATIENT: 2021118-02 - DRED-HARRY, KEVIN .
PATIENT: 2021118-02 - DRED-HARRY, JASON.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}