re = /.*?\s-\s([^.]*?)\s*\./m
str = 'PATIENT: 2029985 - COLLINS, JUNIOR .
PATIENT: 1235231-02 - JERRY JR, PATRICK .
PATIENT: 986435--EXP-- - JULIUS, DANIEL .
PATIENT: 2021118-02 - DRED-HARRY, KEVIN .
PATIENT: 2021118-02 - DRED-HARRY, JASON.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end