import re
regex = re.compile(r"\b(\d{4})\/(\d{2,4})(?:\/(\w{2}))?(?!\S)", flags=re.MULTILINE)
test_str = ("which seems to work properly, but I want to avoid the cases in which for example: I have a string \"2020/2000/WEEEE\" and it matches it.\n\n"
"Other wrong example that it matches: \"IEN/BSK-2020/143999\" .\n\n"
"4444/1234/en")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")