re = /\b(\d{4})\/(\d{2,4})(?:\/(\w{2}))?(?!\S)/m
str = 'which seems to work properly, but I want to avoid the cases in which for example: I have a string "2020/2000/WEEEE" and it matches it.
Other wrong example that it matches: "IEN/BSK-2020/143999" .
4444/1234/en'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end