# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^CN=(.*?)(?<!\\),.*/$1/gm;t' <<< "CN=(A) Gro up3,OU=OU-Path1,OU=OU-Path2,DC=domain,DC=local
CN=(A) Group1,OU=OU-Path1,OU=OU-Path2,DC=domain,DC=local
CN=(A) Gro\,up4,OU=OU-Path1,OU=OU-Path2,DC=domain,DC=local
CN=(A) Group2,OU=OU-Path1,OU=OU-Path2,DC=domain,DC=local"