#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^CN=(.*?)(?<!\\),.*"
Local $sString = "CN=(A) Gro up3,OU=OU-Path1,OU=OU-Path2,DC=domain,DC=local" & @CRLF & _
"CN=(A) Group1,OU=OU-Path1,OU=OU-Path2,DC=domain,DC=local" & @CRLF & _
"CN=(A) Gro\,up4,OU=OU-Path1,OU=OU-Path2,DC=domain,DC=local" & @CRLF & _
"CN=(A) Group2,OU=OU-Path1,OU=OU-Path2,DC=domain,DC=local"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)