# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^CN=(.*?)(?<!\\),.*"
test_str = ("CN=(A) Gro up3,OU=OU-Path1,OU=OU-Path2,DC=domain,DC=local\n"
"CN=(A) Group1,OU=OU-Path1,OU=OU-Path2,DC=domain,DC=local\n"
"CN=(A) Gro\\,up4,OU=OU-Path1,OU=OU-Path2,DC=domain,DC=local\n"
"CN=(A) Group2,OU=OU-Path1,OU=OU-Path2,DC=domain,DC=local")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.