const regex = /\d{2}\:\d{2}\-\d{2}\:\d{2}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{2}\\:\\d{2}\\-\\d{2}\\:\\d{2}', 'gm')
const str = `from 16:00-17:00 we will be bowling and from 18:00-19:00 there is dinner
from 10:00-16:30 we will be bowling and from 18:30-18:45 there is dinner
from 12:00-14:00 we will be bowling and from 15:00-17:00 there is dinner`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}