# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d{2}\:\d{2}\-\d{2}\:\d{2}"
test_str = ("from 16:00-17:00 we will be bowling and from 18:00-19:00 there is dinner\n"
"from 10:00-16:30 we will be bowling and from 18:30-18:45 there is dinner\n"
"from 12:00-14:00 we will be bowling and from 15:00-17:00 there is dinner")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.