$re = '/\d{2}\:\d{2}\-\d{2}\:\d{2}/m';
$str = 'from 16:00-17:00 we will be bowling and from 18:00-19:00 there is dinner
from 10:00-16:30 we will be bowling and from 18:30-18:45 there is dinner
from 12:00-14:00 we will be bowling and from 15:00-17:00 there is dinner';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);