$re = '/(^[^\/]+)/m';
$str = 'Psycholinguistics/Theories_and_Models_
Java_Tutorial/Hello_World!
United_States_currency/$2_bill/dsfkljsd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);