re = /(^[^\/]+)/m
str = 'Psycholinguistics/Theories_and_Models_
Java_Tutorial/Hello_World!
United_States_currency/$2_bill/dsfkljsd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end