package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i).*dpm.*`)
var str = `C:\Program Files\dpm\
C:\Program Files\DPM\cats
C:\Program Files\dogs\
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}