$re = '/(?i).*dpm.*/m';
$str = 'C:\\Program Files\\dpm\\
C:\\Program Files\\DPM\\cats
C:\\Program Files\\dogs\\
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);