re = /(?i).*dpm.*/m
str = 'C:\\Program Files\\dpm\\
C:\\Program Files\\DPM\\cats
C:\\Program Files\\dogs\\
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end