package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.[0-9]-[0-9])`)
var str = `"values-are-10-1,20-2,30-1,40-4,50-3"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}