$re = '/(.[0-9]-[0-9])/m';
$str = '"values-are-10-1,20-2,30-1,40-4,50-3"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);