import re
regex = re.compile(r"(.[0-9]-[0-9])", flags=re.MULTILINE)
test_str = "\"values-are-10-1,20-2,30-1,40-4,50-3\""
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")