using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<=cachorro )corre\w+|(?<=cachorro )foi|(?<=cachorro )pul\w+)|((?<=gato )corre\w+|(?<=gato )foi|(?<=gato )dorm\w+)";
string input = @"O cachorro correu com o gato
O carro passou e o cachorro foi atrás
Sempre que chego em casa meu cachorro pula em mim
Ele foi correndo atrás do sonho
Enquanto o gato correu
O cachorro dormiu
Despois disso o gato dormiu";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}