const regex = /^\s*([a-z]\s*){1,10}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*([a-z]\\s*){1,10}$', 'gm')
const str = `aaa ttt aaa a
bbbbb aazzz
a b c d e f g h i j
abcdefghij `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}