// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*([a-z]\s*){1,10}$").unwrap();
let string = "aaa ttt aaa a
bbbbb aazzz
a b c d e f g h i j
abcdefghij ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}