re = /^\s*([a-z]\s*){1,10}$/m
str = 'aaa ttt aaa a
bbbbb aazzz
a b c d e f g h i j
abcdefghij '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end