import Foundation
let pattern = #"SELECT [\w\s\(\*\)\,]* FROM ticket_file [\w\s\"\'\`\<\>\=]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
SELECT * FROM ticket_file WHERE 1
SELECT id, name FROM ticket_file WHERE id < 100
SELECT COUNT(*) FROM ticket_file
SELECT MAX(id) FROM ticket_file
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)