#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(((.*) (Waukesha|MADISON|NORTHBROOK) (\w{2,}) (\d+(( \d+)*)) \w+) ((.*) (Waukesha|MADISON|NORTHBROOK) (\w{2,}) (\d+)))"
Local $sString = "CORPORATION SERVICE COMPANY 301 S BEDFORD STE 1 MADISON WI 53703 3175 COMMERCIAL AVE STE 201 NORTHBROOK IL 60062 USA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")