// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(((.*) (Waukesha|MADISON|NORTHBROOK) (\w{2,}) (\d+(( \d+)*)) \w+) ((.*) (Waukesha|MADISON|NORTHBROOK) (\w{2,}) (\d+)))").unwrap();
let string = "CORPORATION SERVICE COMPANY 301 S BEDFORD STE 1 MADISON WI 53703 3175 COMMERCIAL AVE STE 201 NORTHBROOK IL 60062 USA";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}